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1. INTRODUCTION 
 
ANSYS is a powerful general purpose finite element modeling package to numerically 
solve a wide variety of mechanical, structural and non-structural problems. These 
problems include: static/dynamic structural analysis (both linear and non-linear), heat 
transfer and fluid problems, as well as acoustic and electro-magnetic problems [1]. In 
general, a finite element solution may be classified into the following three stages. This is 
a general guideline that can be used for setting up any finite element analysis.  
 
Preprocessing: defining the problem 
The major steps in preprocessing are given below:  

• Define key points/lines/areas/volumes  
• Define element types and material/geometrical properties  
• Mesh lines/areas/volumes as required  
 

Solution: assigning loads, constraints and solving 
In the solution level, the loading conditions such as point load or pressure and constraints 
or boundary conditions are specified and finally the resulting set of equations are solved.  
 
Post processing: further processing and viewing of the results 
This stage provides different tools to view the results including:  

• Lists of nodal displacements  
• Element forces and moments  
• Deflection plots  
• Stress contour diagrams  

In this level our job as an engineer is to interpret the output results and verify their 
accuracy. Typically with increasing number of elements (using finer mesh), we should 
expect to more accurate results.  
 
1.1 Starting up ANSYS: 
To start ANSYS in Windows environment simply follow the path: 
Start Menu >Programs >ANSYS 7.1 >ANSYS Classic 
The first window you may see is the main window as shown in Figure 1. 
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ANSYS Toolbar 

 

Utility Menu 

Graphic Window 

Main Menu 
Main Menu 

 
Figure 1: ANSYS main Window 

 
1.2 ANSYS Interface 
There are two methods to use ANSYS; Graphical Interface and Command File Coding. 
The graphical user interface or GUI follows the conventions of Windows based 
programs. This method is probably the best approach for new users. The command 
approach is used by professional users. It has the advantage that an entire analysis can be 
described in a small text file, typically in less than 50 lines of commands. This approach 
enables easy model modifications and minimal file space requirements. In this lab 
manual we mainly use the GUI. However, in some cases both the GUI and command 
code are used to show that how command code could be easy to use.  
 
1.3 ANSYS Files 
When run even a simple program by ANSYS, a large number of files are created. Each 
file has specific purposes. The most important files are described briefly as follows: 
 
FILE.db: Database file (binary). This file stores the geometry, boundary conditions and 
any solutions.  
FILE.dbb: Backup of the database file (binary).  
FILE.err: Error file (text). Listing of all error and warning messages.  
FILE.out: Output of all ANSYS operations (text). This is what normally scrolls in the 
output window during an ANSYS session.  
FILE.log: Logfile or listing of ANSYS commands (text). Listing of all equivalent 
ANSYS command line commands used during the current session.  

 
Note that if you started ANSYS without specifying a jobname, the name of all the files 
created will be FILE.*. If you specified a jobname, then all files will be saved by the 
jobname. 
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When you are using the GUI, then you only require to save the .db file. This file stores 
the geometry, boundary conditions and any solutions. When you start ANSYS you only 
need to “Resume from…” and call your saved file.db 
 
1.4 Plotting of Figures 
To Plot your created model or output results such as deformed shape, you may follow the 
following path.  
Utility menu bar>PlotCtrls>Hard Copy>Graphics window>Monochrome>Reverse 
Video>Landscape>Save to>choose a name>OK.  
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2. STATIC ANALYSIS: TRUSS AND FRAME STRUCTURES 
 
One-dimensional elements can be used in a variety of engineering applications. The 
simplest 1-D element is the link element which is a line with two nodes at the ends as 
shown in Figure 2. Degrees of freedom at each node may consider as displacements in 
length, width and even thickness directions depending upon the application. This element 
can be used as a truss, a link, a spring, etc. Note that in this element no bending is 
considered. 
 

 
 

Figure 2: Link element 
 

2.1 Truss Analysis 
You may recall that a truss is a structural element that experiences loading only in the 
axial direction.  
 
2-D Truss 
As the first application of link element, consider a truss structure shown in Figure 3. 
Determine the nodal deflections, reaction forces, and stress for this structure. (E = 
200GPa, A = 5000mm2). 

 

 
 

Figure 3: 2-D Truss Structure 
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Preprocessing: Defining the Problem  
 
1. Select Title  
In the Utility menu bar select File > Change Title: 
 
2. Create geometry: Nodes 
Preprocessor > Modeling > Create > Keypoints > In Active CS> Use the following 
entries 
 

Keypoints  
1 2 3 4 5 6 7 8 9 10 11 12 

X 0 4.0 8.0 12.0 12.0 10.0 6.0 2.0 0 2.0 6.0 10.0 
Y 0 0 0 0 4.2 4.2 4.2 4.2 4.2 8.4 8.4 8.4 

 
In the main menu select: Preprocessor > Modeling > Create > Lines > Lines > In 
Active Coord. 
 
3. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete.  
Use LINK1 as element type  
 
4. Define Geometric Properties  
In the Preprocessor menu, select Real Constants > Add/Edit/Delete  
Enter the area 
 
5. Element Material Properties 
In the 'Preprocessor' menu select Material Props > Material Models 
Double click on Structural > Linear > Elastic > Isotropic 
 
6. Meshing > Size Cntrls > ManualSize > Lines > All Lines 
In the size 'NDIV' field, enter the desired number of divisions per line. For this example 
we want only 1 division per line, therefore, enter '1' and then click 'OK'. Note that we 
have not yet meshed the geometry; we have simply defined the element sizes.  
In the 'Preprocessor' menu select Meshing > Mesh > Lines and click 'Pick All' in the 
'Mesh Lines' Window. Now you should have the layout shown in Figure 4. 
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Figure 4: 2-D Truss 

 
7. From the Utility Menu (top of screen) select PlotCtrls > Numbering...  
 
8. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
9. From the Solution Menu, select Analysis Type > New Analysis> 
Select Static solution 
 
10. Apply Constraints  
In the Solution menu, select Define Loads > Apply > Structural > Displacement > On 
Nodes 
 
11. Apply Loads 
 Select Define Loads > Apply > Structural > Force/Moment > on Nodes. 
 
12. Solving the System 
In the 'Solution' menu select Solve > Current LS 
- Reaction Forces 
 
Post processing 
 
From the Main Menu select General Postproc > List Results > Reaction Solu. (See 
Figure 5.a and 5.b) 
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Figure 5.a: 2-D Truss –Reaction solutions 

 

 
Figure 5.b: 2-D Truss –list results 

 
Select Plot Results > Deformed Shape (see Figure 6) 
 

 
Figure 6: 2-D Truss –deformed shape 
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From the 'General Postproc' menu select Plot results > Contour Plot > Nodal Solution ( 
see Figure 7) 
 

 
Figure 7: 2-D Truss –nodal solutions 

 
2.2 3-D Truss Structure 
Consider the 3-D truss structure shown in Figure 8. Cross sectional area of all the links 
are A=1.56e-3m2. Material is Aluminum E=75GPa. The structure is fixed in x, y and z 
direction at the bottom three corner. The loading is as shown in the figure. (a) Determine 
deflection at each joint. (b) Determine stress in each member. ( c ) Determine reaction 
forces at the base [2]. 
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Figure 8: 3-D Truss structure 
Preprocessing: Defining the Problem  
 
1. Create key points: Preprocessor>Modeling>Create>Keypoints>In active CS> enter 
the coordinate of key points 
To see the structure in 3-D: Utility Menu>PlotCntrls>Pan Zoom Rotate 
 
2. Create lines: Preprocessor>Modeling>Create>Lines>Lines>In Active Coord. 
Create lines between the key points. 
 
3. Choose materials properties: Preprocessor>Material Props>Material Models. 
Structural>Linear>Elastic>Isotropic. 
 
4. Select element type: Preprocessor>Element Type>Add/Edit/Delete... 
 
5. Mesh the structure: Preprocessor>Meshing>Size Controls>Manual Size>Lines>All 
Lines. 
Preprocessor>Meshing>Mesh>Lines. 
 
Solution 
 
6. Apply boundary conditions: Preprocessor>Loads>Define  
Apply loading: Loads>Apply>Structural>Displacement>On Keypoints 
Preprocessor>Loads>Define Loads>Apply>Structural>Forces/Moment>On Nodes. 
Solve the problem: Main Menu>Solution>Analysis Type>New Analysis. 
 
7. Solution>Solve>Current LS. 
 
Post processing 
 
8. General Postprocessing>List Results>Nodal Solution. 
 
9. General Postprocessing>List Results>Element Solution.  
 
10. General Postprocessing>Plot Results>Contour Plot>Element Solution. 
  
  
2.3 Beam Analysis 
Beams are the most common type of structural component, particularly in Civil and 
Mechanical Engineering. A beam is a bar-like structural member as shown in Figure 9 
whose primary function is to support transverse loading and carry it to the supports.  
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Figure 9: Beam element 

 
 
A beam resists transverse loads mainly through bending action. Bending produces 
compressive longitudinal stresses in one side of the beam and tensile stresses in the other. 
The two regions are separated by a neutral surface of zero stress. The combination of 
tensile and compressive stresses produces an internal bending moment. This moment is 
the primary mechanism that transports loads to the supports.  
 
Analysis of beam structures is very similar to the procedure applied for truss structures 
except: 
 
Element Type > Add/Edit/Delete> Use BEAM 3 as element type  
In the Preprocessor menu, select Real Constants > Add/Edit/Delete> enter moment of 
inertia I and Height, and cross sectional area A. 
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2.4 Lab Assignment 1 
1.  Determine the nodal deflections, reaction forces, and stress for the truss system shown 
in Figure 10 (E = 200GPa, A = 3500mm2). 
 

 
Figure 10: Truss structure- assignment 1 

 
2.  Determine the nodal deflections, reaction forces, and stress for the truss system shown 
in Figure 11 (E = 200GPa, A = 3500mm2). 
 
 

 
Figure 11: Truss structure- assignment 2 
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3. TWO-DIMENSIONAL PROBLEMS 
 
Plate element 
Two dimensional elements are reduced from 3D element by neglecting stress through the 
thickness direction (plane stress). The simplest plane element is a three node triangular 
element shown in Figure 12. In this element each node has two degree of freedom.  
 

 
Figure 12: Plane element 

 
 
3.1 2-D Structure with Different Loadings 
Determine the nodal deflections, and von Mises stress for the structure shown in      
Figure 13. E = 75GPa, Thickness = 0.01m and Poisson Ratio is 0.2. 
 

 

 
Figure 13: Plate structure of with different loadings 

 
Preprocessing: Defining the Problem  
 
1. Select Title  
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In the Utility menu bar select File > Change Title: Plate 1 
 
2. Create geometry: Area 
Preprocessor > Modeling > Create > Areas > Rectangle>By Dimensions> Use the 
following entries 
 

Rectangle X1 X2 Y1 Y2 
1 0 0.1 0 0.1 
2 0.1 0.5 0 0.1 
3 0.5 1 0 0.1 
4 0.5 0.6 0.1 0.5 
5 0.4 0.5 0.4 0.5 

 
 
Assemble the parts. 
Preprocessor > Modeling > Operate> Booleans> Glue > Areas 
 
3. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete.  
Use Plane42 as element type select option plane str w/thk 
 
4. Define Geometric Properties  
In the Preprocessor menu, select Real Constants > Add/Edit/Delete  
Enter the thickness 
 
5. Element Material Properties 
In the 'Preprocessor' menu select Material Props > Material Models 
Double click on Structural > Linear > Elastic > Isotropic 
 
6. Meshing > Meshtools > Pick All 
7. From the Utility Menu (top of screen) select PlotCtrls > Numbering...  
 
8. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
9. From the Solution Menu, select Analysis Type > New Analysis. 
 Select Static solution 
 
10. Apply Constraints  
In the Solution menu, select Define Loads > Apply > Structural > Displacement > On 
Nodes 
 
11. Apply Loads 
 Select Define Loads > Apply > Structural > Pressure > on Lines. 
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12. Solving the System 
In the 'Solution' menu select Solve > Current LS 

- Select Plot Results > Deformed Shape (see Figure 14) 
 

 
Figure 14: Example 3.1-deformed shape 

 
From the Main Menu select General Postproc > Plot Results> Contour Solu  > 
Stress>von Mises. (see Figure 15) 
 

 
Figure 15: Example 3.1-Stress results 

 
 

 16



3.2 2-D Structure with Different Materials and Cross Sections 
Determine the nodal deflections, and von Mises stress for the beam shown in Figure 16 
 
E (CU) = 120GPa, GXY (CU)=44GPa ; E (AL) = 73GPa, GXY (AL)=26GPa  
 
 

 
Figure 16: 2D structures with different materials 

 
 
Preprocessing: Defining the Problem  
 
1. Title  
In the Utility menu bar select File > Change Title: Beam 2 
 
2. Create geometry: Area 
Preprocessor > Modeling > Create > Areas > Rectangle>By Dimensions 
 
Use the following entries 
 

Rectangle X1 X2 Y1 Y2 
1 0 0.6 0 0.4 
2 0.6 0.9 0 0.4 
3 0.9 1.7 0 0.4 

 
3. Preprocessor > Modeling > Operate> Booleans> Glue > Areas 
 
4. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete.  
Use Plane 82 as element type, select option plane str w/thk 
 
5. Define Geometric Properties  
In the Preprocessor menu, select Real Constants > Add/Edit/Delete  
Enter the thickness of CU > Apply > Enter the thickness of AL>OK 
 
6. Element Material Properties 
In the 'Preprocessor' menu select Material Props > Material Models 
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Double click on Structural > Linear > Elastic > Isotropic 
Enter AL properties 
Add new models 
Enter CU properties 
 
7. Preprocessor > > Operate> Booleans> Glue > Areas 
 
8. Meshing > Mesh Attribute > Pick Area> 
 
9. Meshing > Meshtools (Smart Size=4) > Mesh> Pick All 
 
10. From the Utility Menu (top of screen) select PlotCtrls > Numbering...  
 
11. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
12. From the Solution Menu, select Analysis Type > New Analysis. 
 Select Static solution 
 
13. Apply Constraints  
In the Solution menu, select Define Loads > Apply > Structural > Displacement > On 
Nodes 
 
14. Apply Loads 
 Select Define Loads > Apply > Structural > Pressure > on Lines. 
 
15. Solving the System 
In the 'Solution' menu select Solve > Current LS 
Select Plot Results > Deformed Shape (See Figure 17) 
 

 
Figure 17: 2-D structure with different materials_ Deformed shape 
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From the Main Menu select General Postproc > Plot Results> Contour Solu  > 
Stress>von Mises (See Figure 18) 
 

 
Figure 18: 2-D structure with different materials _stress results 

 
 
 
3.3 Plate with Hole 
Determine the stress concentration factor in the plate shown in Figure 19 (a) E x= 
207GPa, GXY =77GPa  
 

 
                      (a)                                                                        (b) 

Figure 19: Plate with a hole 
 
Since the shape is symmetric we may consider only a half of the shape for the analysis as 
shown in Fig.19 (b) 
 
Preprocessing: Defining the Problem  
 
1. Title  
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In the Utility menu bar select File > Change Title: Plate 2 
 
2. Create geometry: Area 
 
Preprocessor > Modeling > Create > Areas > Rectangle>By Dimensions 
X1=0 X2=0.05 Y1=0,  Y2=0.05 
Preprocessor > Modeling > Create > Areas >Circle > Solid Circle 
X, Y =0, 0,  R=0.025 
Preprocessor > Modeling > Operate> Subtract> Areas 
 
3. Meshing > Meshtools (Smart Size=4) > Mesh> Pick All 
 
4. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete.  
Use Plane2 as element type select option plane str w/thk 
 
5. Define Geometric Properties  
In the Preprocessor menu, select Real Constants > Add/Edit/Delete  
 
6. Element Material Properties 
In the 'Preprocessor' menu select Material Props > Material Models 
Double click on Structural > Linear > Elastic > Isotropic 
Enter Material properties 
 
7. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
8. From the Solution Menu, select Analysis Type > New Analysis. 
 Select Static solution 
 
9. Apply Constraints  
In the Solution menu, select Define Loads > Apply > Structural > Displacement > 
Symmetric B.C > On Line 
 
10. Apply Loads 
 Select Define Loads > Apply > Structural > Pressure > on Line. 
Enter -1000 
 
11. Solving the System 
In the 'Solution' menu select Solve > Current LS 
 
12. General Postproc> Plot results>Nodal Solution> von Mises (See Figure 20). 
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Figure 20: Example 2.3_stress contour 

 
13. General Postproc> Plot results>Query Results> Subgrid Solution 
Select von Mises (See Figure 21). 
 

 
Figure 21: Example 3.3_stress results 
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3.4 Lab Assignment 2 
1.  Determine the nodal deflections, reaction forces, and stress for the beam shown in 
Figure 22 (E = 200GPa, I=0.000925m4). Hint: Use Beam element. b = 0.02 ft 
 
 

 
Figure 22: 2-D structure_ assignment 2.1 

 
2.  Determine the nodal deflections, reaction forces, and stress for the truss system shown 
in Figure 23 (E = 200GPa, I=0.000925m4). Hint: Use Beam element. L = 8 m, b=0.2 m 
 

 
Figure 23: 2-D structure_ assignment 2.2 

 
 

3. Consider the square plate shown in Figure 24 of uniform thickness with a circular hole 
with dimensions shown in the figure below. The thickness of the plate is 1 mm. The 
Young's modulus E =107 MPa and the Poisson ratio is 0.3. A uniform pressure p=1 MPa 
acts on the boundary of the hole. Assume that plane stress conditions prevail. Determine 
the stress and displacement fields  

 

 
 

Figure 24: 2-D structure_ assignment 2.3 
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4. DYNAMIC ANALYSIS 
 
4.1 Free Vibration: Solid Structure (Modal Analysis) 
 
Determine the vibration responses of the work table show in Figure 25. 
 
 

 
Figure 23: modal analysis 

 
1 

m
 

2 m

1 
m

 

 
 
 
 
 
 
 
 
 
 
 

Figure 25: Solid structure 
 
Preprocessing: Defining the Problem  
 
1. Title  
In the Utility menu bar select File > Change Title: Work Table 
 
2. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete.  
Select solid45  
 
3. Element Material Properties 
In the 'Preprocessor' menu select Material Props > Material Models 
Double click on Structural > Linear > Elastic > Orthotropic 
Enter density = 415 
Ex=1e10,  GXY=5e8 
 
4. Create geometry: Area 
 
Preprocessor > Modeling > Create > Blocks > By Dimensions>Use the following 
entries 
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Block X1 X2 Y1 Y2 Z1 Z2 
1 0 2 0 1 0 0.05 
2 0.04 0.09 0.04 0.09 0 -1 
3 1.91 1.96 0.91 0.96 0 -1 
4 1.91 1.96 0.04 0.09 0 -1 
5 0.04 0.09 0.91 0.96 0 -1 

 
Plotctrl/zoom/ pan/rotate 
Preprocessor > Modeling > Opreate > ADD > volumes 
 
5. Meshing > Meshtools (Smart Size=4) > Mesh 
 
6. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
7. From the Solution Menu, select Analysis Type > New Analysis. 
 Select modal solution>analysis option> select 5 modes 
 
8. Apply Constraints  
Select>entities>areas/by num/pic> select bottom of legs 
Select entities> nodes>Attached to> areas all >ok 
 Select> everything 
In the Solution menu, select Define Loads > Apply > Structural > Displacement > On 
Nodes> pick all 
 
9. Solving the System 
In the 'Solution' menu select Solve > Current LS 
General post proc> Result summary 
General post proc> Read Result > First set> Plot result> Deformed shape> 
Plotctrl> animate 
The third mode shape is shown in Figure 26. 
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Figure 26: mode shapes of solid structure 

 
 
4.2 Transient Analysis: Spring-Mass System 
Determine transient response of mass 2 of the system shown in Figure 27. 
 

 
Figure 27: transient analysis _spring-mass system 

 
Preprocessing: Defining the Problem  
 
1. Title  
In the Utility menu bar select File > Change Title: mass-spring 
 
2. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete.  
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Use Combin 14 for spring and dampers 
Use Mass 21 for mass uses option 2D without rotation 
 
3. Define Geometric Properties  
In the Preprocessor menu, select Real Constants > Add/Edit/Delete  
Select mass 21 > mass=10 kg 
Select Combin 14 >K=100, CV1=20 
 
4. Create geometry: Nodes 
Preprocessor > Modeling > Create > Nodes 
 
Use the following entries 
N, 1 0, 0 
N, 2, 0,-1 
N, 3, 0,-2 
 
Create element for the masses 
Set the element attribute> define elements> select mass element> select real set 
Create element> auto numbered> through nodes > select node 2> select node 3 
Note: The E commands may be used alternatively as shown below. 
 
Type, 2 
Real, 1 
E, 2; E, 3 
 
Create element for the spring and dampers 
Change the element attribute to spring element > select real set 2 
Create element> auto numbered> through nodes > select nodes 1, 2> select nodes 2, 3 
 
Type,1 
Real,2 
E,1,2; E,2,3 
 
5. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
6. From the Solution Menu, select Analysis Type > New Analysis>Transient 
 
7. Apply Constraints  
In the Solution menu, select Define Loads > Apply > Structural > Displacement > On 
Nodes 
Select Nodes 1 > all DOF 
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8. Apply Loads 
Switch unabridged to abridge menu 
 Select Define Loads > Apply > Structural > Force > on Node> Nodes 2 > Fy=-5 
Select Solution > load step option>Time-Frequency/Time& Substep 
Time at the end of load step =1 
Number of substeps =10 
KBC: Ramped 
Select Solution > Output ctrls /DB-Results file 
Select every load substeps 
Output conrl> Time frequency> time integration> amplitude decay> change Gama 
to 0.1 
Note: Gama may be entered alternatively as shown below. 
Use: TITP, 0.1 (for gama) 
 
9. Solving the System 
In the 'Solution' menu select Solve > Current LS 
 
Preprocessor 
 

- Time Hist. /define variables./add >select modal DOF results 
- Enter: DOF:UY, Ref: 2   Node: 3 label: Y3 
- Time Hist post Proce>variable viewer >Graph 
- PLVAR,2 (see Figure 28) 

 

 
Figure 28: spring-mass system- transient response 

 
The modal solution may be animated using the following sequence. 
General post > Top menu> pltctrl> animate 
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4.3 Lab Assignment 3 
1.  Determine the first five natural frequencies and modes shapes of Guitar string  with 
the length of 700 mm  and diameter of 0.25 mm. the string is made of steel with material 
properties as follows: E = 190GPa, density = 7920 kg/m3, A =196e-9 I = 1.53 e-12 . 
 
Hint: Use Beam 3 element, assume zero displacement at both ends as boundary 
conditions. 
 
2.  Perform the modal analysis on the shell plate clamped in all the edges as shown in 
Figure 29. The dimensions of the plate is H=1, W=2 with the thickness of 0.01 [m]. (E = 
200GPa, Density = 7800 kg/m3).  
 
Hint: Use Shell63 with uniform thickness. 
 
 
 
 
 
 

h 
 
 
 
 w

 
 

Figure 29: clamped-clamped plate_ assignment 3.2 
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5. NON-STRUCTURAL PROBLEMS 
 
5.1 Steady State Heat Transfer  
Determine temperature distribution in the triangular fine shown in Figure 30 with 
constant base temperature of 100 C0: 
 

 
                                                                        h = 80 W/m2 K 

                                                                t = 0.01m 
                                                                   L = 0.025 m 

                                                                        K = 173 W/mK 
 
 
 
 

t 

L

Figure 30: steady state heat transfer 
 
                 
 

Preprocessing: Defining the Problem  
 
1. Title  
In the Utility menu bar select File > Change Title: Fine 
 
2. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete> Plane55.  
In the 'Preprocessor' menu select Material Props > Material Models 
Double click on Thermal> Conductivity > Isotropic> KXX =173 
 
3. Create Geometry: Keypoints 
Preprocessor > Modeling > Create > Key points > In Active CS 
Enter the following: X1=0, Y1=0,  X2=0.025, Y2=0,  X3=0, Y3=0.005 
Preprocessor > Modeling > Create > Lines > Straight Line 
Preprocessor > Modeling > Area-Arbitrary > By Lines >  
 
4. Meshing > Meshtools > Smart Size> 4 
 
5. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
6. From the Solution Menu, select Analysis Type > New Analysis>Steady-state 
 
7. Apply Loads 
Select Define Loads > Apply > Thermal > Temprature > on Node> All left Nodes > 
100  
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Select Define Loads > Apply > Convention > on Lines> Select upper line 
 
8. Solution> Solve > Current LS 
 
Postprocessor 
 
9. Post Pro 
Select Plot Results > Nodal Solution> 
Select Plot Results > Vector Plot-Predefined> 
 
 
5.2 Transient Heat Transfer 
A semi-infinite plane is held at 0 C. Suddenly contact with a fluid with 100 C0 and  
 h = 50 W/m2 K. Determine the heat distribution in the plane after 2 Seconds. Material 
and geometric properties are given bellow. 
 
Material Properties:                   Geometric properties:                 Loading: 
 
K = 54 W/m C0                               a = 1 m                                  T0 = 0 C 
ρ =7833 kg/ m3                               b = 0.1 m                               Te = 1000C 
c = 0.465 kJ/ Kg-C0                                                                       h = 50 W/m2K. 
 
Preprocessing: Defining the Problem  
 
1. Title  
In the Utility menu bar select File > Change Title: Transient heat 
 
2. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete>Plane55  
 
3. Element Material Properties 
In the 'Preprocessor' menu select Material Props > Material Models 
Double click on Thermal > Isotropic 
 
4. Create Geometry: Area 
Preprocessor > Modeling > Create > Rectangle > By 2 Corners 
 
5. Meshing > Meshtools (Smart Size = 2) > Mesh 
 
6. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
7. From the Solution Menu, select Analysis Type > New Analysis> Transient 
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8. Apply Loads 
Select Define Loads > Apply > Thermal > Uniform temp >  
Select Define Loads > Apply > Convention > on Lines> Select upper line 
Enter film coefficients = 50 
Bulk tem = 1000 
Time-Freq/Time-Timesteps 
Time = 2 
Deltime = 0.1 
Stepped load 
Select Solution > Output Ctrls /DB-Results file>Every Substep 
 
9. Solving the System 
In the 'Solution' menu select Solve > Current LS 
 
Postprocessor 
 
10. Post Pro 
General post proc> Read Result > Last set 
General post proc> Read Result > Nodal solution 

- Time Hist. /Define Variables/Add > 
- Enter: DOF: Temp, Ref: 2   Node: 1 , label: Temp  (N,0,1,0) 
- Time Hist post Proce>Variable Viewer >Graph 
- PLVAR, 2 

 
 
5.3 Fluid Analysis 
 
5.3-1 Cylindrical container 
Obtain the shape of the free surface of the liquid in cylindrical container filled with water 
when rotating with the rotational velocity of Ω = 25 rad/s. The height of water inside the 
container is 4 m. The radius of cylinder is 3 m. density of water is 1000 kg/m3

 
Preprocessing: Defining the Problem  
 
1. Title  
In the Utility menu bar select File > Change Title: Swirl  
 
2. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete> Fluid 79.  
Select Axisymmetric from option menu 
In the 'Preprocessor' menu select Material Props > Material 
Models>structural>isotropic >EX=1e20,  
Material Props > Material Models>structural>density > 1000  
 
3. Create Geometry: Area 
Preprocessor > Modeling > Create > Area > Rectangle> by dimension 
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Enter the following: X1=0, Y1=0,  X2=3, Y2=4   
 
4. Meshing > Meshtools > Smart Size> 4 
 
5. Saving Your Work 
On the Utility Menu select File > Save as....  
 
Solution: Assigning Loads and Solving 
 
6. From the Solution Menu, select Analysis Type > New Analysis>static 
 
7. Apply Loads 
Select Define Loads > Apply > displacement > on Node> All right Nodes > UX=0 
Select Define Loads > Apply > displacement > on Node> All left Nodes > UY=0 
Select Define Loads > Apply > Inertia>Gravity > Y direction>9.81 
Select Define Loads > Apply > Inertia > Angular velocity> Global>Y direction>25 
 
Solution 
 
8. Solution> Solve > Current LS 
 
Post Processor 
 
9. Select Plot Results > Deformed shape> 
 
 
5.3-2 Diffusion problems 
Determine the moisture diffusion inside the wooden sphere. 
 
Preprocessor 
 
1. Title  
In the Utility menu bar select File > Change Title: Diffusion 
 
2. Define Element  
From the Preprocessor Menu, select: Element Type > Add/Edit/Delete>Plane35  
Option > Axisymmetic  

 
3. Element Material Properties 
In the 'Preprocessor' menu select Material Props > Material Models 
Double click on Thermal > Conductivity>Isotropic>KXX=4.3e-6 
Thermal>Density>DENS=1 
Thermal>Specific Heat>C=1 

 
4. Create Geometry: Area 
Preprocessor > Modeling > Create > Areas>Circle>Partial Annulus 
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WPX = 0 
WPY = 0 
Rad_1 = 0 
Teta_1 = -90 
Rad_2 = 0.1 
Teta_2 = 90 
 
5. Meshing > Meshtools >Global set>20> Mesh 
 
6. Analysis Type > New Analysis> Transient 
 
7. Define Loads > Apply > Thermal > Temperature>Uniform temp > 70 
 
8. Utility>Select>Entities>Lines>By Num or Pick> Select curved line 
 
9. Utility>Select>Entities>Node>Attached to>Lines-all 
 
10. Solution>Define Loads>Apply>Thermal>Temperature>On Nodes>Pick All> 5 
 
11. Entities>Select>Everything 
 
Solution 
 
12. Solution>Time/Frequency>Time-Time Step>TIME = 200, DELTIME = 10, KBC 
= Stepped Loading 
 
13. Solving the System 
In the 'Solution' menu select Solve > Current LS 
 
Postprocessor 
 
14. General post proc> Read Result > Last set 
General post proc> Read Result > Nodal solution 

- Time Hist. /Define Variables/Add > 
- Enter: DOF: Temp, Ref: 2   Node: 1 , label: Temp  (N,0,1,0) 
- Time Hist post Proce>Variable Viewer >Graph 
- PLVAR, 2 
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5.4 Lab Assignment 4 
 
Problem 1 
A long thick-walled cylinder shown in Figure 31 is maintained at a temperature Ti on the 
inner surface and To on the outer surface. Determine the temperature distribution through 
the wall thickness [3].  
 

 
 

Figure 31:  Thermal analysis_ assignment 4.1 
 

Material Properties
E = 30 x 106 psi 
α = 1.435 x 10-5 in/in-°C 
υ = 0.3 
k = 3Btu/hr-in-°C  

Geometric Properties Loading
a = 0.1875 inches Ti = -1°C 
b = 0.625 inches  T o = 0°C 
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Problem 2 
A tapered rectangular stainless steel cooling fin shown in Figure 32 dissipates heat from 
an air-cooled cylinder wall. The wall temperature is Tw, the air temperature is Ta, and the 
convection coefficient between the fin and the air is h. Determine the temperature 
distribution along the fin and the heat dissipation rate q. Use 2-D Thermal Solid Elements 
(PLANE55) [3]. 
 

 
 

Figure 32:  Thermal analysis_ assignment 4.2 
 
 

Material Properties
k = 15 Btu/hr-ft-°F 
h = 15 Btu/hr-ft 

2-°F 

Geometric Properties Loading
b = 1 in = (1/12) ft Tw = 1100°F 

T a = 100°F 
= 4 in = (4/12) ft  
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6. INTRODUCTION TO CATIA 
 
CATIA is very powerful finite element based software with excellent capabilities in 
design and analysis. Design and modeling with CATIA itself need lots of practice and 
skills which is not in the scope of this tutorial. In this section, in order to show the 
capability of CATIA in finite element analysis a simple beam with distributed loads has 
been introduced. 
 
To start CATIA in Windows environment simply follow the path: 
Start Menu >Programs >CATIA >CATIA V5R10. 
 
The first window you may see is the main window shown in Figure 33. 
 

 
Figure 33:  Main Window of CATIA V5 

 
1. To create the model: Start> Mechanical Design> Sketcher (See Figure 34) 
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Figure 34:  Main Window of CATIA V5 

 
2. Now you should have a window as Figure 35. 
 

 
Figure 35:  Mechanical Design Sketcher  

 
3. Use drawing tools in the right bar to create your model. For example in Figure 36, we 
created an arbitrary rectangle. To add dimension to the line, simply click on Constraint 
option ( ) > select line> double click on the measure line> in the pop up window enter 
the value. 
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For symmetric axis, select upper line+ctrl > select lower line> click on constraints 
key . 
 

 
Figure 36:  Create an arbitrary rectangle 

 

4. To make a three dimensional design, click on   > click on  > in the pop 
window select the width. 

5. To select materials click on   to have a variety of materials to select as shown in 
Figure 37. in this example we select steel. 
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Figure 37:  Select material properties 

 
At this level, modeling session is done. 
 
 6. To start analysis: Start> Analysis & Simulation> Generative Structural Analysis> 
(See Figure 38). 
 

 
Figure 38:  Structural Analysis 
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In the pop up window select analysis type. In this example we select static analysis. (See 
Figure 39) 
 

 
Figure 39:  Static Analysis 

 
7. To apply boundary conditions, select left side> click on   for clamped-support. 
8. To apply load select upper right line > click on  > enter the value and direction of 
load 
9. To solve the problem: click on  . 
10. To observe the results: click on   to see the nodal displacements (See Figure 40).  
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Figure 40:  Nodal displacements 

11. Click on  to see the Von mises stress (See Figure 41). 
 

 
Figure 41:  Von Mises stress 

 
7. REFERENCES 
 
[1] www.mece.ualberta.ca/tutorials/ansys/
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[3]  ANSYS Help manual 
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